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1 Introduction 

1.1 What is LX Styler 

LX Styler is customization tool for LX8000, LX8080, LX9000, LX9050 and LX9070. Using it, 
you will be able to modify existing navigational pages or add new navigational pages. It 
allows you to choose from more than 120 different data symbols to suit your needs. You can 
also change the shape and size of an airplane or remove unnecessary elements. 
Within the manual following the symbols are shown. 
 

 
Yellow triangle is shown for part of manual which should be read very carefully. 

 
Bulb icon is shown when useful hint is given for reader. 

 

1.2 System requirements 

LX Styler is written for Windows operating system. Minimum requirements are simple: 

 Pentium processor 
 Windows XP or higher 
 .NET Framework 2.0 
 15 MB of free disk space 

1.3 Installing and uninstalling 

Download installation program from our webpage www.lxnav.com then run it and follow on-
screen instructions to complete the installation. 
To uninstall a program navigate to uninstall icon in LX Styler group and run it. You can also 
open Control panel, select Add or Remove Programs, find LX Styler line and press Remove 
button. 

1.4 Starting LX Styler 

After successful installation a program group named LX Styler is created and an icon is 
placed on your desktop. Double click the icon to run. 

 

1.5 Get in contact with us 

In case you have difficulties understanding or running LX Styler or you discovered a bug, 
please send us an email to info@lxnav.com or call us +386 592 33 400. 
Visit our webpage regularly for free updates and new help files. 

http://www.lxnav.com/
mailto:info@lxnav.com
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2 Getting Started 

2.1 LX Styler windows 

Once a program is started the main window will show the last configuration opened or it will 
be empty. 

 

The main window consists of menu, toolbar and main view, where all seven navigational 
modes are shown, namely airport mode, waypoint mode, task mode, statistics mode, setup 
mode, info mode and near mode. 
You will notice that the last four modes are in shaded with gray color which means that it is 
not possible to modify them. 
In each mode relevant pages are shown. If you left click twice on any of navigational pages 
the Navigation Page editor will be opened. It is used to define all small details of the selected 
page. 
More details about the Navigation Page Editor are given in chapter 2.4 and 3.2. 
 
 

 
 
 

Global properties 

List of 
symbols 

Property 
editor 

Navigational 

page 

Toobar 
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2.2 Managing configurations 

The complete look and feel of the navigational pages is stored in a configuration file with 
.lxprofile extension. Configuration file can be newly created or it can be also downloaded 
from the device. 
To download configuration file from device enter Setup mode and select Profile and Pilots 
menu item. Press MORE>> until you don’t see TO SD button. Press it to copy selected 
profile to inserted SD card. 

  

You can now load stored configuration file in LX Styler through File->Open or pressing open 
icon on toolbar. 
To create a new configuration press File->New Configuration or select new configuration 
icon on toolbar. 

 

The configuration file also consists of other settings essential for the device. 
Variometer setting, pilot information, files in use and glider polar are also stored 
in the configuration file. Most of these settings can also be modified with LX Styler 
and others can only be changed on device itself. 
If you create a new profile all this settings will be set to default values and you 
will have to modify them on the device. 

Once configuration that suits your needs has been created you can save it with File->Save or 
by clicking the save icon on a toolbar. 

2.3 Managing navigational pages 

Navigational pages can be easily moved, copied or removed using the mouse. A double left 
click on a selected navigation page will open Navigation Page Editor. Press right mouse 
button and a pop up menu will open. 

 

Select appropriate menu item to add, remove, copy or edit page. You can also drag page to 
another location – just press left mouse button and while holding it down, drag selected 
navigational page to desired location. A red line will indicate new position of page. Release 
mouse button to place page. 
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2.4 Navigation Page Editor 

If you left click on any of navigational pages, or you selected Edit page on the popup menu, 
Navigation Page Editor will be opened. It is divided into four sections: 

 Toolbar contains all symbols which can be put on a navigational page. 
 Global properties that define global styles for symbols on it and list of all symbols on 

the page 

 Property editor displays all the properties of selected symbols 
 Graphical representation of the device and navigational page. 
Select one or more items from a list or pick them on the device screen. They will be 
highlighted on the list and a blue rectangle will be drawn around them. Property editor will 
fill in the properties for the selected item. If more than one element is selected property 
editor will show only common properties. 

 

Once you have finished editing a page, press Apply button on the toolbar to accept changes 
and return back to main window. Press Cancel to abandon all changes and return back to 
main window. 

2.4.1 Toolbar 

Select a desired item from the toolbar to place it on page. Some of items will be grayed if 
they are already on the page or they are unavailable. 
Left click on item and it will automatically be placed in the top-left corner of the page. If you 
select Data Symbol a new dialog will open where you can then select the desired symbol. 
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Data symbols are grouped in seven groups: aircraft parameters, outside parameters, target 
parameters, task parameters, optimization data, FES/JDU and misc tab. More details about 
data symbols on particular tab are given in chapter 3.2.2. 
The toolbar also has a delete button which will delete the currently selected item. You can 
also delete an item by pressing delete key. 

2.4.2 Global Styles and Symbols list 

When you want to change color for all symbols on the page simultaneously, you should use 
global styles. There are four different items in this category: 

 Background color defines background color of page. Default color is black 
 Title style defines font, background color, border color and text color of data symbol title 
 Data style defines font, background color, border color and text color of data value 
 Single line symbol style defines font, background color, border color and text color of 

single line data symbols. 

 

 

If you change color or font of any of global styles, it will be applied only to the 
data symbols with property “Use Global Style” set to yes. 

The symbol list shows all elements of a page. Left click on item to select it. It will highlight it 
and a blue rectangle will be drawn around it in graphical view and properties for selected 
item will be shown in property editor. 

2.4.3 Property editor 

Property editor shows all the properties of selected element that can be modified. Property 
editor is a table with two columns. 

 

Left column displays property name and right column displays property value. Click on 
property value to modify it. Press down arrow on right side and additional dialog for selected 
property will be displayed. 

Symbol 
title  

Single line 
symbol 

Symbol 
data 
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At the bottom of property editor more detailed description for selected item is shown. 

2.4.4 Device Screen 

Device screen is a graphical representation of navigational page. 

 

Point to a symbol and select it with left mouse click. If you hold left mouse button on a 
symbol, you can drag it around and place it into the desired position. If you click, hold and 
move small white squares around selection you can resize the symbol. 
To select multiple symbols at once you hold down Ctrl button on your keyboard and then 
click on next symbol you wish to select. Now you can move or resize them together. While 
holding Ctrl click again on selected item to deselect it. 
When resizing or moving, the borders of selected symbol are snapped to borders of other 
symbols; this is indicated with orange line. If you wish to move or resize symbol freely hold 
down Shift key while moving the mouse. 
You can also move selection by 1 screen pixel with keyboard’s arrow keys. To move only 
top-left corner hold down Ctrl while pressing the arrow keys. To move only right-bottom 
corner hold down Shift while pressing the arrow keys. 

2.5 Checklists 

It is possible to open and create checklist pages with LX Styler. Checklists are saved in file 
with .checklists extension. You can activate them on device in Setup > Files and Transfer > 
Checklists. 
When editing a checklists page, two additional buttons are present on toolbar. Check item 
button inserts one checklist item on page. These are special items that you can check, 
uncheck and scroll over them on the device. 
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Button Checklist opens new dialog where you create multiple checklist items faster. You can 
also change style of individual rows. After selecting Create button, items are generated and 
added to page. Now you can reposition them on page or make additional changes. 
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3 Commands 

3.1 Main window 

Main window commands are new configuration, new checklists, open, save, recent files, 
import and exit. Recent files are displayed only if any previous configurations were already 
opened. 
In Convert menu there is a list of other devices that you can convert profile to. 
Tools menu consists of other useful features for modifying profile. It is possible to edit 
settings and change order of remote action buttons. 
In Help menu you can open PDF manual of see program version. 

3.1.1 New configuration 

 

When you select new configuration option a dialog for device selection opens. Here you can 
select device you want to create navigational pages for. For some devices you have two 
options, which are portrait and landscape. After selection, new configuration with default 
navigational pages and default settings is created.  
 

 

The configuration file consists also of other settings essential for the device. 
Variometer setting, pilot information, files in use and glider polar are also stored 
in the configuration file. Most of these settings can also be modified with LX Styler 
and others can only be changed on device itself. 
If you create a new profile all this settings will be set to default values and you 
will have to modify them on the device. 

3.1.2 New checklists 

When clicking New configuration command a device picker dialog opens. After selection, 
empty checklists editor will be displayed with pages on left side and familiar page editor in 
center. 

3.1.3 Open 

Open option opens existing configuration file or checklists. If you already used program for 
editing, you can open some of recently opened files from the list in File menu. 

3.1.4 Save 

Save command saves current configuration or checklists file. 
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3.1.5 Import 

Imports pages from existing profile to currently opened one. You can manually select which 
modes and pages you want to import. If you wish to also import all setting saved in profile 
(such as map settings, opened waypoints, units settings, sound and graphics settings…) then 
check Import all settings option. 

 

3.1.6 Exit 

Exit will close LX Styler. Make sure you save your configuration before exiting program. You 
may also exit program pressing Alt+F4 key combination. 

3.1.7 Convert 

Converts currently opened profile for use on other devices. If there are any settings in profile 
they are preserved. If screen sizes are not the same on current and target device the 
program tries to resize and move symbols on all pages to fit target screen size. 

3.1.8 Profile editor 

You can access Profile Setting Editor from Tools menu. There you can select one of many 
profile groups and then edit individual settings. 
You can only edit setting that device already has saved to profile file. So if you just created 
new profile in LX Styler you cannot edit them because they don’t exist yet. 
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3.1.9 Remote actions editor 

From Tools menu you can access editor with which you can reorder navigation buttons for 
remote stick. This customization is available for airport mode, waypoint mode and task 
mode. You can enable or disable custom order of buttons in mode with toggling 
corresponding checkbox. When enabled you can reorder buttons with clicking and dragging 
them up or down inside the list. 

3.1.10 Edit page 

When you right click on a page a popup menu will appear. Select Edit Page item and 
Navigation Page Editor will then open. 

3.1.11 Add page 

Select this option to add a blank page. Page can be added before selected page or after it. 

3.1.12 Remove page 

Select Remove page to delete a page. 

3.1.13 Copy page 

Page can be also copied. Select a page and copy it to a local clipboard. Once page is copied 
it can be pasted afterwards. 

3.1.14 Paste page or style 

This will create a copy of a page from the clipboard. It will be placed after selected 
navigation page. You can also paste global styles from copied page into selected page. 

3.1.15 Set as thermal 

This will set current selected page as thermal page. When this feature is enabled on device 
selected page will be shown when circling. 

3.1.16 Enable/disable mode 

If you do not need to use one or more navigation modes you can disable them with 
unchecking the checkbox on mode header. 

3.1.17 Home mode 

Click on home button on mode header bar to open on this mode first when you start the 
device. 
 

3.2 Navigational Page Editor 

Navigation Page Editor is divided into four major sections.  
 Toolbar is containing all symbols which can be put on a navigational page. 
 Global properties define global colors for page symbols; Bellow is a list of all 

symbols on the page 
 Property editor for displaying properties of selected symbols 
 Graphical representation of device and navigational page. 

3.2.1 Toolbar 
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The toolbar contains the different symbols which can be placed on a navigational page. Most 
symbols can be placed only once on a page and will be disabled if they are already on a 
page. 
Some of the symbols can be placed on a page only in combination with others and will be 
disabled if a particular symbol is missing. (e.g.: zoom symbol can be placed on a page only if 
map and aircraft symbols are already on the page.) 
When you click on data symbol selector a dialog will open. 

 

Data symbols are grouped in seven logical groups: aircraft parameters, outside parameters, 
target parameters, task parameters, optimization data, FES/JDU and misc tab. More details 
about specific symbols are given in next chapter. 
On the toolbar there is also a delete button for removing a symbol from page and buttons 
Apply and Cancel for exiting the editor. 

3.2.2 Symbols 

Map symbol 

A map will be added to a page. By default it will be stretched to the whole screen. Select 
edge points to resize it or to move it around. Map symbol is always added together with 
aircraft symbol. 

Aircraft symbol 

The aircraft symbol shows the current position on the map. The aircraft symbol will 
automatically be added together with the map. 
You will notice there are actually two aircraft symbols shown. The one drawn as a shadow is 
showing position of on airplane when Track Up, Goal Up or Heading Up map orientation is 
selected on the device (See device’s manual for more details about map orientation). In 
property editor this position is referred as Track and the other position is referred as North. 
There are several types of aircraft available. Change style to select different aircraft symbol.  
You can also show a wind vector, which will rotate around the symbol. 
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3D Map 

Symbol shows map with 3D terrain. This feature is not available on some older LX8000 and 
LX9000 devices. 

Battery 

Battery will visually display current level of battery. Green indicates that battery is ok. It will 
turn yellow and later red, when battery is empty. 

Orientation symbol 

Orientation symbol points always towards true north. It can be placed on a page only when 
map symbol is already on a page. 

Final glide symbol 

Final glide symbol is very complex symbol and it is highly recommend having it on the page. 
It will display current MacCready value, arrival altitude at goal and many other features 
which are very important for task start procedure. Please refer to device manual for more 
details. 

Wind symbol 

Wind symbol shows wind direction. It is useful to combine it with wind data symbol in order 
also to get wind strength. Around wind symbol a thermal assistant can be shown during 
circling. Enable or disable this feature with “Has Thermal” property. 

GPS symbol 

GPS shows current status of GPS. Green color indicates GPS is acquiring 3D position and 
yellow color stands for 2D position fix. When red no position is calculated by GPS. Each bar 
represents two visible satellites. 

Zoom symbol 

Zoom symbol shows current map zoom. It can be used only when the map symbol is already 
on the page. Zoom can be presented in two ways; number on symbol indicates the length of 
the zoom symbol or number indicates length of whole screen. Use “Full” property to modify 
it. 

Data symbol 

There are a variety of data symbols available. A data symbol is a numerical representation of 
different parameters. A data symbol consists of title field, which stores name of data symbol 
and data field which is shown as the parameter. Title can be omitted if Show title property is 
set to No. When „Use Global Style” property is set to Yes, data symbol will follow global page 
style properties. Disabling „Use Global Style” property allows a full customization of selected 
data symbol. 

AHRS symbol 

This will display artificial horizon. You can also set it to see compass direction. It is available 
in 3 different display styles. 

Radar symbol 

Flarm radar symbol will display a radar screen showing Flarm targets at predefined zoom. If 
on device there is no map symbol on page you can also change visible range with ZOOM 
button wheel. 
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Altitude tape symbol 

It shows altitude band with current altitude in the middle. You can customize it to see 
different information on top and bottom of symbol. This data are QNH, MSL, height above 
ground and flight level. 

Airspeed tape symbol 

Shows current indicated aircraft speed. Band colors can be fully customized to match your 
aircraft speeds. You can also set it to display true airspeed, groundspeed or outside 
temperature. 

Flaps tape symbol 

It displays current and required flaps position. You can center on any of these two positions 
or you can display full tape range. In this case all flap position ranges are spaced equally 
regardless of their values. 

History view symbol 

This shows past aircraft altitude and terrain elevation. Circling direction is also visible. You 
can specify how many minutes of flight should be shown with Shown Minutes property. By 
default value is zero which shows history of whole flight. 

Side view symbol 

Shows lateral view of your position toward selected goal or aircraft‘s bearing. It also displays 
airspaces on your way which you can customize on device inside Airspace graphics dialog in 
setup mode. 

Wind profile symbol 

Symbol displays wind profile information. It is very similar to tape in Wind dialog. 

Picture symbol 

This symbol displays photos tied to selected waypoint or airport. 

Compass and HSI symbols 

These two symbols are displaying magnetic rose. Compass is always attached to plane 
symbol while HSI symbol can be moved freely. Compass tape is another symbol with similar 
functionality that always centers on plane heading. 

Wi-Fi symbol 

This shows current status of your Wi-Fi connection. Note that Wi-Fi functionality does not 
work on some older LX8000 devices. 

Vario symbols 

Vario gauge is representation of variometer. You can change to what values needle is 
pointing to. Vario tape symbol shows vario value on vertical tape. There is also separate SC 
Vario indicator that displays current vario mode. 

Thermal symbol 

This is thermals graph from Statistics mode in symbol form. 

G-meter symbol 

Symbol shows gauge of current g-load value. It also shows smallest and biggest recorded 
value. You can set it to be visible only when it’s over certain g-load. 
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Meteogram  

Symbol shows weater information for selected target. Wi-Fi connection is required to 
download the image. 

FLARM Indicator 

Indicator shows direction and vertical position of other aircraft.  
 

 

Values written in data symbols inside LX Styler are totally useless and are not 
correlated to each other. These values are only for demonstration purposes. 
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Data symbols 

There are more than 120 different data symbols. They are grouped into seven groups. 
 
Aircrafts parameters 
Title Description 

Vario Current vertical speed 

VarA Averaged vertical speed (average time can be set on device) 

Thermal Last thermal vertical speed 

Netto Current netto vertical speed 

Alt Altitude above MSL 

AltIGC Altitude from IGC pressure sensor 

RawIGC Raw IGC altitude 

AltGps GPS Altitude  

Gnd Terrain elevation 

Agl Height above ground 

FL Flight level 

FlIGC Flight IGC altitude 

GS Groundspeed 

TAS True airspeed 

STF Speed to fly 

reqSTF Speed to fly for required MacCready (used for Pirker final glide) 

Trk Groundtrack 

Hdg Heading 

E Current glide ratio 

Th.E Thermal glide ratio 

Emc MacCready glide ratio 

Mc Set MacCready value 

Time Local time 

Date Local date 

UTC Time Current UTC time 

LON/LAT Current longitude and latitude position 

Battery Battery voltage 

IAS Indicated airspeed 

thE Theoretical glide ratio 

VarioFL Average vario for flight 

AltGain Gained altitude in thermal 

reqFlaps Requested flaps position 

curFlaps Current flaps position 

g-load Current g-load 

g-min Minimum g-load 

g-max Maximum g-load 

Circ.Flt Flight circling 

Circ.Tsk Task circling 

Circ.60 Circling in last 60 minutes 

Sp.60’ Last 60 minutes speed 

FltTime Time of flight 

Ballast Current ballast 

Radius  Circling radius 
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FES/JDU 
Batt.Left Remaining battery level (in minutes or percent) 

 
Misc 
Title Description 

Label An arbitrary text label. You can type whatever text you like inside. 

Airspace name Distance to nearest airspace 

Location name Nearest location 

Airport name Nearest airport 

Wpt.name Nearest waypoint 

tmDist Team partner distance 

tmBrg Team partner bearing 

tmVario Team partner vario 

tmAlt Team partner altitude 

tmName Team partner name 

tmRelAlt Relative altitude of teammate 

tmTo Relative bearing of teammate 

tmCode Teamcode of my position 

tmWptCode Waypoint teamcode 

Eng.TT Engine total time 

Eng.FF Engine flight time 

Flarm Flarm RXTX 

COM Active Frequency 

STBY Passive Frequency 

XPDR XPDR Transponder 

Rain Status Rain data status 

Rain Age Age of displayed rain image 

TkOff Takeoff time 

 
Optimization data 
Title Description 

Opt Optimized distance 

OptHome Optimized distance to home 

Tri Optimized FAI triangle distance 

OLC.Sp.60’ OLC 60 minutes speed 

Sp.150’ Last 150 minutes speed 

Alt.150’ Altitude 150 minutes ago 

 
Outside parameters 
Title Description 

Wind Current wind with direction and strength 

cWind Head/Tail wind component. There are two values displayed. First is 
calculation based on track and wind direction and second is difference 
between TAS and GS. 

WindX Side wind component. Displays strength and direction. 

OAT Outside temperature 

Humidity Relative humidity. (A special sensor must be attached to device) 

Dew.Temp Dewpoint temperature. (A special sensor must be attached to device) 

Pot.Temp Potential temperature 
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Target parameters 
Title Description 

Dis Distance to target 

Arrival Arrival altitude at target 

ArrMc0 Arrival altitude at target with MacCready setting=0 

ReqAlt Required altitude to reach target 

Brg Bearing to target 

Radial Radial from target 

To Steering course to target 

ETA Estimated time of arrival 

ETE Established time en route 

reqE Required glide ratio to target 

Target Target name 

Req.Mc Required MacCready value to target, which takes into account also wind. 

Elevation Target elevation 

Rwy.Dir Target runway direction 

Rwy.Len Target runway length 

Frequency Target frequency 

Sunrise & 
Sunset 

Sunrise and sunset time at target location 

Description Additional description of target 

METAR Raw or parsed target METAR data 

TAF Raw or parsed target TAF data 

toWind Head/tail wind to target. There are two values displayed. First is 
calculation based on bearing and wind direction and second is difference 
between TAS and GS. 

Code Target code 

VMG Velocity made good 

 
Task parameters 
Title Description 

tDis Remaining task distance 

Fin.Elev Task finish elevation 

tArr Arrival altitude on task finish calculated through all remaining task points 

tArrMc0 Arrival altitude on task finish calculated through all remaining task points 
with MacCready set to 0 

tETA Task estimated time of arrival 

tETE Task established time 

tRemain Task remaining time 

tDelta Task delta time. A difference between tETA and tRemain 

tskE Required task glide ratio 

Tsk.Sp Task speed so far 

tReq.Sp Task required speed calculated from tRemain and tDis 

tSp.60’ Last 60 minutes task speed 

tReq.Mc Required MacCready value towards next task point, which takes into 
account also wind. 

trqSTF Required speed to fly calculated from required MacCready 

T.Start Alt Task start altitude 

xTrk Current leg cross track distance 

tVario Average vario for task 

sDis Distance to zone center 



LX Styler version 6.0  January 2017 

 Page 22 of 24 

sBrg Bearing to zone center 

csDist Cross distance to zone center 

tunAlt Task uncompensated arrival altitude 

 

3.2.3 Message symbol 

This is special symbol which represents notifications visible on your device. You can’t change 
symbol for each page separately but only for every mode (airport, waypoint and task). It is 
displayed after you select it bellow list of symbols. Now it is possible to resize and move the 
symbol. If you want to hide message symbol you need to deselect it or select some other 
symbol from list on the left side. 

3.2.4 Color editor 

Color editor is used to define a color for a selected property. The color dialog will open if you 
click on down arrow in property value cell. 

 

Color can be selected from a grid of predefined colors on the left side of dialog. Or you may 
change red, green and blue values with sliders or enter numerical values. Color can also be 
set with hexadecimal value. 
 
It is also possible to define opacity for selected color. Slide opacity slider towards zero to 
make selected property transparent. 

3.2.5 Font Style 

If you click on font style property a font style dialog will open. 

 

Different font styles can be selected there and also optional text outline. 

3.2.6 Text Alignment 

Text alignment popup dialog is used to define how text is aligned inside a symbol. 
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3.2.7 Ranges  

Items like G-meter and Data symbol can use ranges for its display. With ranges editor you 
can modify their appearance when symbol value changes. 
In center there are series of value and color controls. Edit value to constrain ranges and 
select color to change appearance of range. On some symbols text can start blinking when 

value enters specified range. Press on “ ” button after color selector on ranges where you 
want blinking to occur. Preview of ranges is drawn on left side of list.  

 

You can add new or remove range with + and – buttons on bottom left. After pressing the 
button, hover over tape on left side and click on range to remove it or split it in two. On 
bottom right side there is possible to select unit in which values are written in. 
 

 

If ranges preview is drawn as diagonal lines while editing this means that written 
values are invalid or are not defined in ascending order.  
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4 Revision history 

December 2009 Initial release of manual 

May 2015 Described new symbols, dialogs and functionality 

September 2016 New checklists file format and new symbols; Updates and typo fixes 

January 2017 Updated range editor, described 2 new symbols 

 


